Before you can install AppAddict 3 there are a few requirements:
Your device must be JailBroken, have AppSync installed and running iOS 6

How to install appsync?

Logo

slider Slide to install